What are the system recommendations for VenueOps?

VenueOps is a webapp and is used exclusively within Internet browsers. Because of this, our system recommendations are quite simple and easy to meet:

  • Your browser must support HTML5 and CSS3. Chrome and Safari are the only browsers that are officially supported for use with VenueOps, although we do a good amount of testing in Firefox, as well. You should always ensure that your browser is updated to the latest version.
  • A reliable broadband Internet connection.
  • 4GB of RAM minimum.
  • Because our software is web-based, we do not have explicit operating system requirements. Your operating system must be new enough, though, to support the latest versions of the above browsers.

Still need help? Contact Us Contact Us